Printer-friendly copy
Top MechCommander MechCommander 2 Technical Issues topic #969
View in linear mode

Subject: "Mechcommander on Windows 7 help" Previous topic | Next topic
Wolf105Wed Apr-20-11 09:05 PM
Member since Apr 20th 2011
10 posts
Click to send email to this author Click to send private message to this authorClick to view this author's profileClick to add this author to your buddy list
"Mechcommander on Windows 7 help"


          

i am trying to play MC2 on Windows 7 64bit. when ever i try to run it, it takes for ever to get it going and then half the time it will freeze at the beginning cinematics, if i happen to get past that i get to the menu and it takes it about 2 min for the computer to realize that i clicked on campaign. and if im lucky enough to successfully load up a mission after 10 min
the graphics are terrible and most of the game info is missing ,health bars, minimap everything you essentially need to play the game.
this is a great game and if anybody has any suggestions please help

here are my pc specs

OS: windows 7 64bit
processor: AMD Sempron Processor 3300+ 2.00ghz
RAM: 1.5 g
Vidcard: ATI Radeon HD 2600/3600 series
graphics memory: 763 MB
directX: version 10



i dont know if this is enough info or even the correct info, but if you can help please do.

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Replies to this topic

wolfmanFri Apr-22-11 09:56 AM
Member since Apr 15th 2003
351 posts
Click to send email to this author Click to send private message to this authorClick to view this author's profileClick to add this author to your buddy list
#1. "RE: Mechcommander on Windows 7 help"
In response to Reply # 0


  

          

Do you try the original MC2 or any mod?
In case you try the original version the first check needs to be that the files vidcard and badcard are deleted
Any mod does not carry those files anymore anyhow

check out wolfman's missions and wolfman's forum at
http://s2.invisionfree.com/wolfman_x_forum/index.php

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

    
Wolf105Fri Apr-22-11 04:28 PM
Member since Apr 20th 2011
10 posts
Click to send email to this author Click to send private message to this authorClick to view this author's profileClick to add this author to your buddy list
#2. "RE: Mechcommander on Windows 7 help"
In response to Reply # 1


          

i used to run it windows xp good, reliant xp. one of my friends upgraded my pc so i could play the newer games. and i already have deleted the files. does the mods fix the problem? and if i were to download these mods how would i get them to work with MC2?

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

        
wolfmanFri Apr-22-11 04:39 PM
Member since Apr 15th 2003
351 posts
Click to send email to this author Click to send private message to this authorClick to view this author's profileClick to add this author to your buddy list
#3. "RE: Mechcommander on Windows 7 help"
In response to Reply # 2


  

          

Quote

i used to run it windows xp good, reliant xp. one of my friends upgraded my pc so i could play the newer games. and i already have deleted the files. does the mods fix the problem? and if i were to download these mods how would i get them to work with MC2?



I have no idea what causes your problems. None of the current expansions or mods are compatible with the original MC

check out wolfman's missions and wolfman's forum at
http://s2.invisionfree.com/wolfman_x_forum/index.php

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

TheOldManFri Apr-22-11 10:47 PM
Member since Jun 16th 2010
28 posts
Click to send email to this author Click to send private message to this authorClick to view this author's profileClick to add this author to your buddy list
#4. "RE: Mechcommander on Windows 7 help"
In response to Reply # 0


  

          

I've run into quite a few issues with MC2 on Vista 32, and Win7 32. They almost always ended up relating to a bad install.
I run it on a 3.0 ghz AMD and it still loads slow for the initial screen. I have no experience on a 64 bit OS, so can't help there.
I even had problems when I upgraded my Graphics card. That ended up being a driver problem.

Try a re-install, and try different compatibility modes.
(Right click on the desktop icon for MC2, click on properties, then click on compatibility tab.)

Hope this helps.

Quidquid Latine dictum sit, profundum viditur.
(Whatever is said in Latin appears profound)

  

Alert Printer-friendly copy | Reply | Reply with quote | Top

Top MechCommander MechCommander 2 Technical Issues topic #969 Previous topic | Next topic
Powered by DCForum+ Version 1.27
Copyright 1997-2005 DCScripts.com